Newer firmware shows msg corruption with old Vista 20SE

General Discussion

Re: Newer firmware shows msg corruption with old Vista 20SE

Postby mathewss » Sun Nov 15, 2020 8:53 pm

Ok lab is about setup ready to test. I have a few older SE panels I finally got my hands on that I also need to test too.

Send me your panel firmware info for reference. A picture of the eeprom or just the text info on it.

I have a few hundred units to get out Monday then I have a few days to work on SE testing.

Thanks.
SM
mathewss
Moderator
Moderator
 
Posts: 135
Joined: Fri Dec 06, 2013 11:14 am

Re: Newer firmware shows msg corruption with old Vista 20SE

Postby latenitetech » Sun Nov 15, 2020 10:03 pm

Thx for the attention to this. I see 2 labels on my panel PCB, not sure which one is useful to you.
On the large heat sink is a label with this text:

SAVSADT-1
ASSY, PCB Vista-20ADT w/E2 MICR

On the other label (adhered to the CPU chip, I believe) is the text:
I WA20ADT-3.1 Copyright PITTWAY 2000 REV. 4.1

Hopefully one of those labels is the firmware info you're looking for. I'm also attempting to attach a pic, but I've had poor luck doing attachments in the past. Also, potentially useful, the system is branded as an "ADT Safewatch Pro 2000 / Security Manager 2000."

Thx! Mark

PS - unable to upload attachment - getting error (in red) "Sorry, the board attachment quota has been reached." Not sure if that's specific to me as a newbie, or something about the board. Anyway, hopefully the text above is adequate.
latenitetech
newt
newt
 
Posts: 11
Joined: Sat Sep 19, 2020 1:38 pm

Re: Newer firmware shows msg corruption with old Vista 20SE

Postby mathewss » Mon Nov 16, 2020 2:30 pm

Sorry about that. I need to do some maintenance here but never enough time :(

Ok I added more space It should work now.

This is the panel I am testing with. I believe it is the same as you have. An early version of the 20SE panel.
I was able to test today and saw the same results. Normal messages work "ish" and programming messages don't work at all.

If it does not work you can send me the pic at coder@f34r.com

20201116_125033.jpg
20201116_125033.jpg (2.74 MiB) Viewed 57 times


Best
SM
mathewss
Moderator
Moderator
 
Posts: 135
Joined: Fri Dec 06, 2013 11:14 am

Re: Newer firmware shows msg corruption with old Vista 20SE

Postby latenitetech » Mon Nov 16, 2020 3:32 pm

The board in your pic doesn't look anything like mine, but if you're getting the same results, I'll take that as progress. I've attached a pic of my board for reference. Per the docs I have (from the previous owner), it was originally installed in 07/2000. Also, if it's helpful, in my original post I mentioned it seemed to work fine with firmware version 2.2a.6, the one labeled "ADEMCO OLD Protocol." Just thinking you might be able to see what got changed in the firmware after 2.2a.6 that may have broken this, or what changed in the AD webapp that makes it incompatible with that older firmware now.

Also, I did do some limited testing with the Windows Keypad App V2.0.10 and I believe it worked with both the older and current firmware versions, so a viable option may be to get the webapp working with the older firmware it that's the shorter path to success.

Either way, I'm happy you're looking at it and assume you'll find a workable fix.

Thx! Mark

IMG_20201116_165605546.jpg
PCB - ADT Safewatch Pro 2000
IMG_20201116_165605546.jpg (987.79 KiB) Viewed 57 times
latenitetech
newt
newt
 
Posts: 11
Joined: Sat Sep 19, 2020 1:38 pm

Re: Newer firmware shows msg corruption with old Vista 20SE

Postby mathewss » Fri Nov 20, 2020 5:05 pm

Some progress. Spent a few days digging into that part of the code. It looks very different than a earlier model SE panel.

I will have fun getting it to work with both :( I will probably just send an update to you for this specific panel and then work on getting it to work with both.

Let me know where I can send firmware updates. Did you have a Ticket # from my support system I can reply with the firmware?

Best
SM
mathewss
Moderator
Moderator
 
Posts: 135
Joined: Fri Dec 06, 2013 11:14 am

Re: Newer firmware shows msg corruption with old Vista 20SE

Postby latenitetech » Fri Nov 20, 2020 6:05 pm

I have a ticket in your support system from when I first purchased the AD2pHAT back on 9/3/20. The ticket from that communication was [Nu Tech #53464]. Or you can just use the e-mail address I have listed with my account on this board (same one). I assume you can just send the firmware file as a attachment in e-mail since it's so small, or send me a link to download it.

Looking forward to testing with it.

Thx!

Mark
latenitetech
newt
newt
 
Posts: 11
Joined: Sat Sep 19, 2020 1:38 pm

Previous

Return to General

Who is online

Users browsing this forum: No registered users and 3 guests

cron