Upgrading to latest stable fw (2a-8-8) corrupted messages

General Discussion

Upgrading to latest stable fw (2a-8-8) corrupted messages

Postby billfor » Sun Oct 27, 2019 6:04 pm

After upgrading from 2_2a_8_2 to 2-2a-8-8 it seems like all the messages are corrupted. From the data stream I get the following which should just be a simple DISARMED CHIME Ready to Arm . Is there some other change that I need to make on the new fw or should I revert back to the old one?

Thanks.

[00001400011001000A--],0ff,[f700000080ff442043000000000000]," DIS Ready to Arm ( ARMED CH"
[01001100001100003A--],0ff,[f700000080ff494d45000000000000]," DISady to Arm ( ARMED CHIME "
[00001010010001000A--],0ff,[f700000080ff202052000000000000]," DISto Arm ( ARMED CHIME Re"
[00001111101101001A--],0ff,[f700000080ff616479000000000000]," DISrm ( ARMED CHIME Ready "
[00000400100101113A--],0ff,[f700000080ff746f20000000000000],"rm DISARMED CHIME Ready to A"
[00000200100101013A--],0ff,[f700000080ff726d20000000000000]," DISARMED CHIME Ready to Arm "
[00001001001100001A--],0fe,[f700000080fe204449000000000000]," DISD CHIME Ready to Arm ( "
[11001101001100100A--],0ff,[f700000080ff41524d000000000000]," DISIME Ready to Arm ( ARME"
[00001400011001000A--],0ff,[f700000080ff442043000000000000]," DIS Ready to Arm ( ARMED CH"
[01001100001100003A--],0ff,[f700000080ff494d45000000000000]," DISady to Arm ( ARMED CHIME "
[00001010010001000A--],0ff,[f700000080ff202052000000000000]," DISto Arm ( ARMED CHIME Re"
[00001111101101001A--],0ff,[f700000080ff616479000000000000]," DISrm ( ARMED CHIME Ready "
[00000400100101113A--],0ff,[f700000080ff746f20000000000000],"rm DISARMED CHIME Ready to A"
[00000200100101013A--],0ff,[f700000080ff726d20000000000000]," DISARMED CHIME Ready to Arm "
[00001001001100001A--],0fe,[f700000080fe204449000000000000]," DISD CHIME Ready to Arm ( "
[11001101001100100A--],0ff,[f700000080ff41524d000000000000]," DISIME Ready to Arm ( ARME"
[00001400011001000A--],0ff,[f700000080ff442043000000000000]," DIS Ready to Arm ( ARMED CH"
billfor
Junior Nut
Junior Nut
 
Posts: 23
Joined: Wed Mar 01, 2017 4:32 pm

Re: Upgrading to latest stable fw (2a-8-8) corrupted message

Postby mathewss » Sun Oct 27, 2019 6:09 pm

Is this an SE panel?

Any chance you can send more info
Version command and config command responses.

Best
Sean M
mathewss
Moderator
Moderator
 
Posts: 80
Joined: Fri Dec 06, 2013 11:14 am

Re: Upgrading to latest stable fw (2a-8-8) corrupted message

Postby billfor » Sun Oct 27, 2019 6:33 pm

Hi, yes this is a VISTA20-SE
I tried downgrading through the UI with the old fw that I downloaded from the web site but get the following error:
c:\pathtof\zipfile.zip is not a valid hex file.
But I opened the file and it does contain a valid hex.

!VER:ffffffff,V2.2a.8.8,TX;RX;SM;VZ;RF;ZX;RE;AU;3X;CG;DD;MF;L2;KE;M2;CB;DS;ER;CR

Thanks.
billfor
Junior Nut
Junior Nut
 
Posts: 23
Joined: Wed Mar 01, 2017 4:32 pm

Re: Upgrading to latest stable fw (2a-8-8) corrupted message

Postby billfor » Sun Oct 27, 2019 6:36 pm

Also if you need it:
!
!>Ademco/DSC Mode A/D (A) :>
!>Keypad Address (31) :>

!WARNING. Do not enable a module if the physical module exists
!Zone Expanders Y/N Max allowed: 02
!>expander module #01 ZN 09-16 (N) :>

!>expander module #02 ZN 17-24 (N) :>

!>expander module #03 ZN 25-32 (N) :>

!>expander module #04 ZN 33-40 (N) :>

!>expander module #05 ZN 41-48 (N) :>

!Relay Modules Y/N Max allowed: 04
!>relay module #01 (N) :>

!>relay module #02 (N) :>

!>relay module #03 (N) :>

!>relay module #04 (N) :>

!>Emulate Long Range Radio Y/N: (N) :>

!>Emulate modem COM Y/N: (N) :>

!>Address Filter Mask (ffffffff) :>

!>Deduplicate (N) :>

!>Config Bits (ff00) :>

!Reading configuration.
!UART init.
billfor
Junior Nut
Junior Nut
 
Posts: 23
Joined: Wed Mar 01, 2017 4:32 pm

Re: Upgrading to latest stable fw (2a-8-8) corrupted message

Postby billfor » Sun Oct 27, 2019 7:18 pm

OK. I managed to get it to downgrade -- for some reason I couldn't figure out how to get it to take local file.

Anyway, I'm back on the 2a8.2 and it is working normally again. Maybe a problem with the Vista20SE panels?

My normal messages look like this:
[00000001100000003A--],0fc,[f700000080fc000c28000000000000]," DISARMED CHIME Press * Key "
[00000001100000003A--],0fc,[f700000080fc000c28000000000000]," DISARMED CHIME Press * Key "
[00000001100000003A--],0fc,[f700000080fc000c28000000000000]," DISARMED CHIME Press * Key "
[00000001100000003A--],0fc,[f700000080fc000c28000000000000]," DISARMED CHIME Press * Key "
[00000001100000003A--],0fc,[f700000080fc000c28000000000000]," DISARMED CHIME Press * Key "

The reason I upgraded btw is that I still have a weird issue where it goes into the config menu if I cold start the rpi by plugging the power in. I got tired off typing =. and going through the menus everytime and thought maybe there was a fix in the latest fw. Not ruling out a problem with my rpi config but wanted to check.....

If you want me to troubleshoot I can go back on the 8-8.
billfor
Junior Nut
Junior Nut
 
Posts: 23
Joined: Wed Mar 01, 2017 4:32 pm

Re: Upgrading to latest stable fw (2a-8-8) corrupted message

Postby mathewss » Sun Oct 27, 2019 7:26 pm

All my current work is in 8.9

Did it work? I did make some timing changes. With some help we can get it sorted.

Best
Sean M
mathewss
Moderator
Moderator
 
Posts: 80
Joined: Fri Dec 06, 2013 11:14 am

Re: Upgrading to latest stable fw (2a-8-8) corrupted message

Postby billfor » Sun Oct 27, 2019 7:34 pm

Downgrading works fine. If you want me to try another version let me know which one.
billfor
Junior Nut
Junior Nut
 
Posts: 23
Joined: Wed Mar 01, 2017 4:32 pm

Re: Upgrading to latest stable fw (2a-8-8) corrupted message

Postby mathewss » Sun Oct 27, 2019 8:30 pm

Try the latest beta 2.2a.8.9 I pushed a few days back.

Best
Sean M
mathewss
Moderator
Moderator
 
Posts: 80
Joined: Fri Dec 06, 2013 11:14 am

Re: Upgrading to latest stable fw (2a-8-8) corrupted message

Postby billfor » Mon Oct 28, 2019 3:30 pm

Same issue:
!Ademco Keypad Emulator V2.2a.8.9b-306
!Copyright (C) 2008-2015 Nu Tech Software Solutions, Inc.

Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
!SER2SOCK Connected
!SER2SOCK SERIAL_CONNECTED
[00001010010001000A--],0ff,[f700000080ff202052000000000000]," DISto Arm ( ARMED CHIME Re"
[00001111101101001A--],0ff,[f700000080ff616479000000000000]," DISrm ( ARMED CHIME Ready "
[00000400100101113A--],0ff,[f700000080ff746f20000000000000],"rm DISARMED CHIME Ready to A"
[00000200100101013A--],0ff,[f700000080ff726d20000000000000]," DISARMED CHIME Ready to Arm "
billfor
Junior Nut
Junior Nut
 
Posts: 23
Joined: Wed Mar 01, 2017 4:32 pm

Re: Upgrading to latest stable fw (2a-8-8) corrupted message

Postby mathewss » Mon Oct 28, 2019 3:35 pm

Ok. Thanks for testing. I will review my change logs. I think it still works with some SE panels but not all. If you could please send me info on your firmware version on the panel.

In will post updates on next steps here. Feel free to keep nudging me on this thread for progress reports.

Best
Sean M
mathewss
Moderator
Moderator
 
Posts: 80
Joined: Fri Dec 06, 2013 11:14 am

Next

Return to General

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron