Pi needs help

General Discussion

Pi needs help

Postby gt3mike » Tue Dec 27, 2022 9:20 am

My AD2PI is sick. The daughterboard alarm panel functionality is working just fine. But the Pi itself is exhibiting a couple of problems.

1) For one thing the alarm keypad on the webapp says "Please Wait Loading" and never appears to finish loading.

2) Also there is this error in the App tab of the Web UI:

Code: Select all
2022-12-27 08:25:14,716 INFO: AlarmDecoder Webapp booting up - v0.8.0-10-g0b754de [in /opt/alarmdecoder-webapp/ad2web/decoder.py:218]
2022-12-27 08:25:14,773 ERROR: Error [in /opt/alarmdecoder-webapp/ad2web/app.py:175]
Traceback (most recent call last):
File "/opt/alarmdecoder-webapp/ad2web/app.py", line 168, in init_app
app.decoder.init()
File "/opt/alarmdecoder-webapp/ad2web/decoder.py", line 238, in init
self._discovery_thread = DiscoveryServer(self)
File "/opt/alarmdecoder-webapp/ad2web/discovery.py", line 60, in __init__
sock.setsockopt(socket.IPPROTO_IP, socket.IP_ADD_MEMBERSHIP, mreq)
File "<string>", line 1, in setsockopt
error: [Errno 19] No such device


I appear to have plenty of storage available.

Code: Select all
pi@alarmdecoder:/ $ df
Filesystem     1K-blocks    Used Available Use% Mounted on
/dev/root        2187128 1659480    396832  81% /
devtmpfs          469548       0    469548   0% /dev
tmpfs             473880       0    473880   0% /dev/shm
tmpfs             473880    6324    467556   2% /run
tmpfs               5120       4      5116   1% /run/lock
tmpfs             473880       0    473880   0% /sys/fs/cgroup
/dev/mmcblk0p1     61384   21296     40088  35% /boot
pi@alarmdecoder:/ $


I very rarely use the web UI, so this problem may have existed for awhile now. I'm running a Raspian 8 image and an older AD2 daughterboard firmware. Given the age of the OS, perhaps my best bet would be to load the newest stable OS image. But I set it up so long ago, I don't remember what changes to the basic image I made the last time, and I'd need to figure those out all over again. So I figured I'd post here first to see if anyone had any other suggestions first.

Any advice would be appreciated.

Thanks
gt3mike
newt
newt
 
Posts: 13
Joined: Sat Feb 03, 2018 3:49 pm

Re: Pi needs help

Postby gt3mike » Tue Jan 03, 2023 4:21 pm

I went ahead and applied the latest stable Raspian 10 image from the download area here. Then I updated the AlarmDecoderWebapp and AlarmDecoderLibrary to the most current version.

But I'm still experiencing the same problem.
    - My home automation server (Indigo) successfully and reliably communicates bidirectionally through the pi via port 10000 with the panel (Vista 21IP).
    - But the webapp running on the pi cannot interact with the panel. It seems to time out waiting for info.

Any suggestions? I'm still on the 2.2a.6 legacy firmware for the AD2 daughterboard, and I'm reluctant to fool with that unless I can get this resolved.

Screen Shot 2023-01-03 at 5.11.18 PM.png
Screen Shot 2023-01-03 at 5.11.18 PM.png (65.41 KiB) Viewed 6228 times
gt3mike
newt
newt
 
Posts: 13
Joined: Sat Feb 03, 2018 3:49 pm

Re: Pi needs help

Postby gt3mike » Wed Jan 04, 2023 9:49 am

A little more info in case it helps. Here's what I'm seeing on port 10000:

mike@Mac-mini ~ % nc 192.168.0.115 10000
!AUI:0b040000000052fefefefe
!AUI:09040000000053fd37
!AUI:0e040000000054feec0101010000
!AUI:09040000000055fd37
!AUI:0b040000000056fefefefe
!AUI:09040000000057fd37

=

!sn:ffffffff
!boot....................
!
!Ademco Keypad Emulator V2.2a.6
!Copyright (C) 2008-2010 Nu Tech Software Solutions, Inc.
!Reproduction without permission is prohibited
!By Sean Mathews <drwho at f34r.com>
!For support emailmake_clickable_callback(MAGIC_URL_EMAIL, ' ',make_clickable_callback(MAGIC_URL_EMAIL, ' ',make_clickable_callback(MAGIC_URL_EMAIL, ' ', '''general@support.nutech.com', '', '')', '', '')', '', '')
!www.NuTech.com
!Reading configuration.
!UART init.
!Ready. Press ! for configuration.
!AUI:09040000000053fd37
!AUI:0e040000000054feec0101010000
!AUI:09040000000055fd37
!AUI:0b040000000056fefefefe
!AUI:09040000000057fd37
!AUI:0e040000000050fefeec01010101
!AUI:09040000000051fd37
[1000000100000000----],008,[f70400ff1008001c08020000000000],"****DISARMED**** Ready to Arm "
!AUI:0b040000000052fefefefe
!AUI:09040000000053fd37
!AUI:0e040000000054feec0101010000
!AUI:09040000000055fd37
!AUI:0b040000000056fefefefe
!AUI:09040000000057fd37
!AUI:0e040000000050fefeec01010101
!AUI:09040000000051fd37
[1000000100000000----],008,[f70400ff1008001c08020000000000],"****DISARMED**** Ready to Arm "
!AUI:0b040000000052fefefefe
!AUI:09040000000053fd37
!AUI:0e040000000054feec0101010000
!AUI:09040000000055fd37
!AUI:0b040000000056fefefefe
!AUI:09040000000057fd37
!AUI:0e040000000050fefeec01010101
!AUI:09040000000051fd37
gt3mike
newt
newt
 
Posts: 13
Joined: Sat Feb 03, 2018 3:49 pm

Re: Pi needs help

Postby gt3mike » Thu Jan 05, 2023 7:49 am

Looking in github it seems like this is a known issue. I made the changes listed in Socket IO ACL not setup. Keypad not working. stuck in Please Wait Loading but it still isn't working.
gt3mike
newt
newt
 
Posts: 13
Joined: Sat Feb 03, 2018 3:49 pm

Re: Pi needs help

Postby gt3mike » Fri Jan 06, 2023 11:54 am

Looks like the problem was the daughterboard firmware. I upgraded to 2.2a.8.8 and all is well again.
gt3mike
newt
newt
 
Posts: 13
Joined: Sat Feb 03, 2018 3:49 pm


Return to General

Who is online

Users browsing this forum: No registered users and 1 guest

cron