SmartThings API Doesn't Discover Device

General Discussion

SmartThings API Doesn't Discover Device

Postby BravoCharlie » Sun Mar 11, 2018 10:51 am

Trying to integrate my AD2Pi Network Appliance with SmartThings using the Readme at https://github.com/nutechsoftware/alarm ... martthings

I get down to:
Install SmartApp...Click the Discover button. You'll probably have to hit refresh a couple of times to get your device to show up. If it doesn't show up make sure you're running an up-to-date version of the webapp.

I get: Select device(s) (0 found). Clicking Refresh is not helping. I have WebApp v0.8.0-8-g57438d1. I tried Googling and came up empty. I deleted what had been accomplished in the API under SmartApps up to that point and tried again with the same result.

Unfortunately, my "expertise" ends there. :( Any ideas or would this be better addressed with the SmartThings community?

Bob
BravoCharlie
newt
newt
 
Posts: 4
Joined: Thu Mar 08, 2018 9:11 pm

Re: SmartThings API Doesn't Discover Device

Postby kevin » Sun Mar 11, 2018 4:46 pm

Look at the logs on the pi in /opt/alarmdecoder-webapp/instance/ and /var/log/gunicorn.d and see if the discovery thread started ok.. also make sure you have support for upnp
Not an employee of the company. Just here to help and keep things clean.
kevin
Platinum Nut
Platinum Nut
 
Posts: 992
Joined: Fri Aug 16, 2013 10:10 am

Re: SmartThings API Doesn't Discover Device

Postby BravoCharlie » Mon Mar 12, 2018 1:21 pm

It was the UPNP.

Thx,
Bob
BravoCharlie
newt
newt
 
Posts: 4
Joined: Thu Mar 08, 2018 9:11 pm

Re: SmartThings API Doesn't Discover Device

Postby grayzweb » Fri Aug 30, 2019 9:28 am

BravoCharlie wrote:It was the UPNP.

Thx,
Bob

I'm having same problem. I checked router and UPNP is enabled. What else can I check?

Thanks
grayzweb
newt
newt
 
Posts: 7
Joined: Sun Aug 25, 2019 12:27 pm

Re: SmartThings API Doesn't Discover Device

Postby grayzweb » Sat Aug 31, 2019 3:51 am

kevin wrote:Look at the logs on the pi in /opt/alarmdecoder-webapp/instance/ and /var/log/gunicorn.d and see if the discovery thread started ok.. also make sure you have support for upnp


I searched event logs in AlarmDecoder web app and could not find either of these entries. ?
grayzweb
newt
newt
 
Posts: 7
Joined: Sun Aug 25, 2019 12:27 pm


Return to General

Who is online

Users browsing this forum: MSN [Bot] and 1 guest

cron