Oddities encountered while running the setup routine

General Discussion

Oddities encountered while running the setup routine

Postby PiAlarmGuy » Fri Jun 07, 2019 3:24 pm

I first want to say that I was very happy to trip across Alarm Decoder once I had discovered that my EVL3 module would not work with my older Ademco Vista 20SE panel. It was also an interesting Pi-based project to get up to running.

I did stumble across some issues which I had wanted to share and ask about. Pre-testing it on a DSC 832 panel went quickly and without issue, having studied Alarm Decoder's setup process well in advance.

Here's my problem description with trying to get Alarm Decoder to work with the Ademco Vista 20SE panel:

1) When I ran the setup program I chose "Ademco" and address 31, as required. However, it then got stuck at the "Saving device configuration". That perplexed me as I wasn't expecting that to happen.

2) From prior and newer experience, I cleaned up the database via this stock series of commands but that did not fix the issue.

cd /opt/alarmdecoder-webapp
sudo rm instance/db.sqlite
python manage.py initdb
sudo reboot

3) When accessing the API via PUTTY and telnet I noticed an oddity. When I executed the "!" configuration routine it would immediately jump to the "Keypad Address" parameter and not allow me to change the mode from 'D' to 'A'. Is this a bug or by-design?

!>Ademco/DSC Mode A/D (D) :>
!>Keypad Address (19) :>

3b) That got me thinking so I then tried a brute force method:

CMODE=A --> Change to Ademco
CADDRESS=31 --> Change keypad address to 31

By doing so I was able to start up the "Setup" program again and it did run to completion.

So, would these issues with the Web-based setup program be known issues for the older Vista SE 20 panel?
PiAlarmGuy
newt
newt
 
Posts: 1
Joined: Wed Jun 05, 2019 2:06 pm

Return to General

Who is online

Users browsing this forum: No registered users and 0 guests

cron