Email notifications no longer working

General Discussion

Email notifications no longer working

Postby Maxburn » Tue Jun 04, 2019 3:28 am

Just noticed that notification emails (which come to my text message, the whole reason for having this device) are no longer working. Not sure why either.

In several log files I'm seeing this;
Code: Select all
Jun  4 07:06:59 AlarmDecoder kernel: [  134.814093] random: crng init done
Jun  4 07:06:59 AlarmDecoder kernel: [  134.814101] random: 7 urandom warning(s) missed due to ratelimiting
pi@AlarmDecoder:/var/log $ sudo cat kern.log


Jun  4 07:06:59 AlarmDecoder kernel: [  134.814093] random: crng init done
Jun  4 07:06:59 AlarmDecoder kernel: [  134.814101] random: 7 urandom warning(s) missed due to ratelimiting
pi@AlarmDecoder:/var/log $ sudo cat messages


Further when I go into the webapp and hit save and test email I get this error in red on the page top;
Code: Select all
Error sending test notification: getrandom() initialization failed. (_ssl.c:661)


There have been ZERO changes to the configuration of Alarm decoder and other devices I have are able to send email from that email account I'm using so the problem definitely is in alarmdecoder. Alarmdecoder email worked last week. Apt is all up to date.



I think this is unrelated, but I get a lot of this in the logs;
Code: Select all
Jun  4 07:05:53 AlarmDecoder sm-msp-queue[578]: unable to qualify my own domain name (AlarmDecoder) -- using short name

I tried this but it didn't seem to help;
https://linuxconfig.org/sendmail-unqual ... d-hostname
Maxburn
Senior Nut
Senior Nut
 
Posts: 46
Joined: Sat Feb 28, 2015 4:57 pm

Re: Email notifications no longer working

Postby Maxburn » Fri Jun 07, 2019 6:25 am

I noticed I was three commits behind, updated and checked apt to see everything up to date there. Rebooted and still same problem.
Maxburn
Senior Nut
Senior Nut
 
Posts: 46
Joined: Sat Feb 28, 2015 4:57 pm

Re: Email notifications no longer working

Postby Maxburn » Wed Jun 12, 2019 4:59 pm

So apparently this forum and product have been abandoned? We have spam posts that have stayed here for days and no answers. That's really sad.
Maxburn
Senior Nut
Senior Nut
 
Posts: 46
Joined: Sat Feb 28, 2015 4:57 pm

Re: Email notifications no longer working

Postby Maxburn » Sun Jun 16, 2019 4:51 am

I spent some time yesterday backing up my config, imaging a fresh SD card with the image posted here. Got it up and running, did all updates and restored my config. Email worked yesterday, today it did not with the same error. Noticed there were now some updates showing in the web app that didn't show yesterday, did those and email works again. I really don't know what to think here, seems I can't rely on this thing any more.
Maxburn
Senior Nut
Senior Nut
 
Posts: 46
Joined: Sat Feb 28, 2015 4:57 pm


Return to General

Who is online

Users browsing this forum: No registered users and 0 guests