Build Ser2Sock fails

General Discussion

Build Ser2Sock fails

Postby digger » Mon Nov 26, 2018 7:58 pm

Hi, I have tried to build Ser2Sock on three different servers.

I was using https://github.com/nutechsoftware/ser2sock#installation-debianubuntu for the installation.

On both Ubuntu 14 and 16 LTS it fails with:

Code: Select all
...
dh_installchangelogs
   dh_installinit
   dh_perl
   dh_usrlocal
dh_usrlocal: debian/ser2sock/usr/local/bin/ser2sock is not a directory
rmdir: failed to remove 'debian/ser2sock/usr/local/bin': Directory not empty
dh_usrlocal: rmdir debian/ser2sock/usr/local/bin returned exit code 1
debian/rules:13: recipe for target 'binary' failed
make: *** [binary] Error 1
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
debuild: fatal error at line 1376:
dpkg-buildpackage -rfakeroot -D -us -uc -i -b failed


I then tried building on Raspbian 9, it got much further but still failed.

Code: Select all
...
make[1]: Entering directory '/home/pi/ser2sock'
make[1]: Leaving directory '/home/pi/ser2sock'
   create-stamp debian/debhelper-build-stamp
 fakeroot debian/rules binary
dh binary  --with autotools-dev
dh: Compatibility levels before 9 are deprecated (level 8 in use)
   dh_testroot
   dh_prep
   dh_auto_install
dh_auto_install: Compatibility levels before 9 are deprecated (level 8 in use)
   make -j1 install DESTDIR=/home/pi/ser2sock/debian/ser2sock AM_UPDATE_INFO_DIR=no
make[1]: Entering directory '/home/pi/ser2sock'
make[2]: Entering directory '/home/pi/ser2sock'
make[2]: Nothing to be done for 'install-exec-am'.
 /bin/mkdir -p '/home/pi/ser2sock/debian/ser2sock.'
  /usr/bin/install -c ser2sock '/home/pi/ser2sock/debian/ser2sock.'
make[2]: Leaving directory '/home/pi/ser2sock'
make[1]: Leaving directory '/home/pi/ser2sock'
   dh_install
dh_install: Compatibility levels before 9 are deprecated (level 8 in use)
   dh_installdocs
dh_installdocs: Compatibility levels before 9 are deprecated (level 8 in use)
   dh_installchangelogs
dh_installchangelogs: Compatibility levels before 9 are deprecated (level 8 in use)
   dh_installinit
dh_installinit: Compatibility levels before 9 are deprecated (level 8 in use)
   dh_perl
   dh_usrlocal
dh_usrlocal: debian/ser2sock/usr/local/bin/ser2sock is not a directory
rmdir: failed to remove 'debian/ser2sock/usr/local/bin': Directory not empty
dh_usrlocal: rmdir debian/ser2sock/usr/local/bin returned exit code 1
debian/rules:13: recipe for target 'binary' failed
make: *** [binary] Error 1
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
debuild: fatal error at line 1116:
dpkg-buildpackage -rfakeroot -us -uc -i -b failed


All three system have:

Code: Select all
sudo apt-get install build-essential autotools-dev devscripts libssl-dev
[sudo] password for digger:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
autotools-dev is already the newest version (20150820.1).
build-essential is already the newest version (12.1ubuntu2).
devscripts is already the newest version (2.16.2ubuntu3).
libssl-dev is already the newest version (1.0.2g-1ubuntu4.13).
0 upgraded, 0 newly installed, 0 to remove and 73 not upgraded.
digger
newt
newt
 
Posts: 1
Joined: Mon Nov 26, 2018 6:33 pm

Return to General

Who is online

Users browsing this forum: No registered users and 1 guest