Page 1 of 1

Vista 20p - AD2USB - Raspberry Pi 3...Then to VERA via WIFI

PostPosted: Sun Sep 08, 2019 5:23 pm
by TheBobC
So, can I do this? I feel like I am so close. Here is what I have accomplished thus far:

1. Got the AD2USB talking to my mac (mostly...still displayed Waiting First Message)
2. Got the AD2USB talking and functioning through Vera USB Port(mostly...always displayed Can't Detect Device, but it worked and displayed zones)
3. Got the A2DUSB functioning via the Web App THROUGH the Raspberry Pi. Can control the Ademco board perfectly from any browser on the local network

Now, I have disconnected the USB cable from the A2DUSB to the Vera and tried changing the connectivity info in the Vera to be the local address of the Raspberry Pi, but I get a Missing Port error, as well as a can't find device. Do I need to delete all port info from before? How would I do this. Or is what I want to do even possible?

Re: Vista 20p - AD2USB - Raspberry Pi 3...Then to VERA via W

PostPosted: Mon Sep 09, 2019 11:52 am
by mathewss
Ya this does work. The Vera supports connecting to the AD2PI over port 10000.

Connect your AD2USB to your Pi and boot the AD2WEB services. If configured correctly you will be able to see alarm messages and arm/disarm from the WEB app. Then from Vera select (very fuzzy here) the socket com port settings and set the IP address of the Pi and port 10000.

Not sure why no love on the MAC. Not heard much about your panel itself. Most common reason the GUI App on PC/MAC/Linux shows loading is because it is not connected to the COM port for the AD2USB or the IP Address of the AD2Pi so it does not get any messages. I would have to see the log tab details to know more.

I do have a vera here and I "think" it was last setup and working this way but I would have to dig further. Will find time if you are still stuck in the next 2 days.

Sean M