Page 1 of 1

Vista20P Programming mode

PostPosted: Sat Jan 26, 2019 6:32 pm
by edk4971
TLDR: How do I click # and * at the same time on the GUI?

I purchased an AD2USB a couple weeks back, and I have what appears to be a rare problem, based on limited search results. The wall panel that I have (Ademco 6150) cannot be used to program the control panel (Vista-20P) as it is a fixed-word display and the Vista requires an alphanumeric display to enter programming mode. After some trial and error, I reconfigured the AD2USB as address 16, and disconnected the 6150. AD2USB is connected (via USB) to a RPI, running ser2sock, and I have a good connection with it from my Windows 10 laptop running the AlarmDecoder keypad app. I do not know the installer code, so the only way to enter programming mode is to press * and # at the same time, within 50 seconds of booting the Vista.

How do I press two keys at once on the AlarmDecoder keypad app?

The only search result which seemed promising is this one, but it didn't work: ... =4&id=1864
Obviously that post is a bit dated, so I'm not sure if something has changed, or if I'm doing it wrong, but I connected Putty to port 10000 on the RPI, watched the boot process, hit Ctrl-E 3 times with no result other than it echos the last boot process message.

Any suggestions?

Re: Vista20P Programming mode

PostPosted: Sun Jan 27, 2019 10:34 am
by mathewss
You are correct that the you need to send a CTRL+E to the panel during the first N seconds after a full power up. The AD2USB will reboot and after it reboots presumably if it is configured for address 16 already you can send a CTL+E 3 times and it will send the "#+*" special key.

The problem is the terminal putty is probably not dealing with this correctly. the actual character sent as described in the AD2* protocol is chr(5) sent three times. ... g-an-alt-c

Maybe a way exists in putty to setup a macro?

Can you connect a monitor and keyboard to your Pi?
If so just login with the pi user and run telnet localhost 10000 and then your ctl+e will work.

You will know it worked because it will show a "!sending.done" message.

Another option is to boot a knoppix disk or some linux on your laptop to get arround the CTL+ character stuff. Telnet from a knoppix terminal will work.

I would be easy to write some code to open the port and send it maybe a quick plugin for the GUI Keypad app. It would take me just a few minutes to modify the "button" example to send chr(5).

In any case access to these special modes is a little more difficult by design to prevent accidental triggering.

Sean M

Re: Vista20P Programming mode

PostPosted: Sun Jan 27, 2019 11:33 am
by mathewss
It was a bug. well kinda. The GUI Keypad app had code to send F1-F4 as well as ctl+e but it was not working. I have fixed it.

I will work on an update later but for now here is the dll for the keypad screen. Note that the code for this screen is available in the module.

I added a global to track the last key since it is not passed for some reason. This will prompt to confirm if confirmation is enabled.

Pressing Left or Right ALT and then e will trigger the special key.

ALT+a is F1 etc.

Code: Select all
      /// <summary>
      /// Handle keypresses for the panel
      /// </summary>
      /// <param name="key">
      /// A <see cref="Gdk.Key"/>
      /// </param>
      private void HandleKey(Gdk.Key key, uint keyval, Boolean isAlt)

         if (key == Gdk.Key.F1) {
            /* show help */;
         /* function key hotkeys */               
         if ( (lastkey == Gdk.Key.Alt_L || lastkey == Gdk.Key.Alt_R)
            & (key == Gdk.Key.a || key == Gdk.Key.A      
             || key == Gdk.Key.b || key == Gdk.Key.B      
             || key == Gdk.Key.c || key == Gdk.Key.C
             || key == Gdk.Key.d || key == Gdk.Key.D
            || key == Gdk.Key.e || key == Gdk.Key.E))

Re: Vista20P Programming mode

PostPosted: Mon Jan 28, 2019 3:05 am
by edk4971
Thank you very much Sean, I'll give it a try this week and let you know my results!

Re: Vista20P Programming mode

PostPosted: Wed Feb 06, 2019 7:14 pm
by edk4971
It looks like the alt-e combination is working (as I can use it to set off the panic alarm) however it still doesn't enter programming mode as advertised. I suspect the company who set it up initially set the *88 "Program Mode Lockout Options" code to one of the options that prohibits access (either downloader only, or installer code only).

I tried the obvious combinations for the installer code (1234, last 4 of the company phone number, etc) but no luck so far. I don't suppose you have something in your toolkit for this?

Re: Vista20P Programming mode

PostPosted: Wed Feb 06, 2019 8:55 pm
by mathewss
Yes indeed I do.
Nothing is 100% but my unlocker module may be able to rescue you depending on the lockout type. Sure worth a shot.

You will need my free keypad gui up and running to use the module.

You will need to remove the alarm bell just in case it sets of a panic code and it will try all codes from 0001-9999 and try to access programming mode. It takes about 1 or two hours to run as I recall. It will BEEP! a lot at each real keypad so removing keypads is a good option as well. Reduces any chance of errors as it hits the panel as fast as it can.

Email me at and let you download to try out. Its only $20 and just for my coffee funds so I would be glad to help by letting you try it out and see if it helps and report back for others and help me improve it for others.

Sean M

Re: Vista20P Programming mode

PostPosted: Fri Feb 08, 2019 5:23 pm
by edk4971
Thanks for the recommendation, I bought it to try it out. Looks like the keypads now lock after a 4 or 5 attempts. Here's the message:
"User Code Error: Keys 0-9 Locked"

Re: Vista20P Programming mode

PostPosted: Fri Feb 08, 2019 5:43 pm
by mathewss
Ouch :( they really did a number on that panel sorry to hear that. I do have one final solution but it will wipe out your programming.
If interested I will have to dig on the specifics but it involves shorting 2 test pads on the board as you power it up.

Sean M